about summary refs log tree commit diff
path: root/third_party/rust-crates/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-04-02T20·03+0200
committersterni <sternenseemann@systemli.org>2021-04-03T22·46+0000
commitabe1de4302a3650cbadbb343630d2f24d232d3f2 (patch)
tree6c60c457694f00055556125b6ad9dbc741961e1d /third_party/rust-crates/default.nix
parent9a1480d314d32b54e3bd548bf53eb3ac2423e21b (diff)
feat(3p/rust-crates): get dependencies from the depot fix point r/2421
I think it is good practice to always get dependencies from the depot
fix point if they are exposed. The reasoning for this is that if we
improve the support for overriding in depot, say by introducing a
depot.extend functions or even full blown overlay support, this will
already work as expected.

Change-Id: Ibb8dffcf32e8f46817a2db2da26139fabdce55bc
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2770
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'third_party/rust-crates/default.nix')
-rw-r--r--third_party/rust-crates/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/third_party/rust-crates/default.nix b/third_party/rust-crates/default.nix
index 17479bf61a..04b7ff869e 100644
--- a/third_party/rust-crates/default.nix
+++ b/third_party/rust-crates/default.nix
@@ -6,7 +6,9 @@ let
     ;
 in
 
-rec {
+with depot.third_party.rust-crates;
+
+{
   cfg-if = pkgs.buildRustCrate {
     pname = "cfg-if";
     crateName = "cfg-if";