about summary refs log tree commit diff
path: root/third_party/re2/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-10-07T19·57+0200
committersterni <sternenseemann@systemli.org>2021-10-10T10·03+0000
commit04f7cc3880912abb738d3d3bc20e7622a211f25e (patch)
treef140a021234bcfdfa2a64e2892fb5eb069595b43 /third_party/re2/default.nix
parentac17de3cbd2c5bcb1d12992c2fe5c6a554ab4716 (diff)
fix(3p): resolve linker issues with clang-compiled C++ packages r/2956
The point where this broke is likely when llvmPackages_11.stdenv started
respecting stdenv.hostPlatform.linker and thus using GNU binutils'
ld.bfd for linking. That linker can't deal with clang's C++ ABI.

To fix this we introduce a modified version of llvmPackages_11.stdenv
which uses llvmPackages_11.bintools for linking purposes (I also aim to
upstream this in some form, but am not sure about the details atm, so
we'll just do this in the tvl overlay for now). This is the precondition
for getting our C++ packages in //third_party to work
again. Additionally the following fixes were necessary:

* abseil-cpp needed to be updated (by overriding the version from
  nixpkgs for now, since I can't update the subtree on my own) to
  fulfill grpc's requirements (grpc 1.41.0 needs abseil-cpp LTS
  20210324).

* gtest needs a patch from nixpkgs which fixes the path to its include
  directory for CMake.

* We need to build re2 with clang as well, otherwise linking will fail.

Fixes b/132.

Change-Id: I7b64579fe96451547babe070fd35db398581e49d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3701
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--third_party/re2/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/third_party/re2/default.nix b/third_party/re2/default.nix
new file mode 100644
index 0000000000..62bce9e2ee
--- /dev/null
+++ b/third_party/re2/default.nix
@@ -0,0 +1,5 @@
+{ pkgs, ... }:
+
+pkgs.re2.override {
+  stdenv = pkgs.fullLlvm11Stdenv;
+}