about summary refs log tree commit diff
path: root/third_party/rapidcheck/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-10T00·13+0200
committertazjin <mail@tazj.in>2021-04-10T11·48+0000
commit8361b82d0ac59f436f7ecef283077b0f7d689ca1 (patch)
tree15f9649ae9f3381c7218ea4f46fc9979a12f11bd /third_party/rapidcheck/default.nix
parent8d4b2f3d54e760ab9f7f8242370a54ff20796553 (diff)
refactor(third_party): Consistent use of depot.third_party vs. pkgs r/2461
In preparation for the solution of b/108, we need to consistently use
`depot.third_party` for packages that are only packed in the TVL depot
and `pkgs` for things that come from nixpkgs.

This commit cleans up a huge chunk of these uses in //third_party

Change-Id: Ic382c0cdea7330a84d5f0b7d109c824ddceb94e7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2912
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'third_party/rapidcheck/default.nix')
-rw-r--r--third_party/rapidcheck/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/third_party/rapidcheck/default.nix b/third_party/rapidcheck/default.nix
index eba1d9ca45..a442f7f991 100644
--- a/third_party/rapidcheck/default.nix
+++ b/third_party/rapidcheck/default.nix
@@ -1,6 +1,6 @@
 { pkgs, ... }:
 
-(pkgs.callPackage "${pkgs.nixpkgsSrc}/pkgs/development/libraries/rapidcheck" {
+(pkgs.callPackage "${pkgs.path}/pkgs/development/libraries/rapidcheck" {
   stdenv = pkgs.llvmPackages.libcxxStdenv;
 }).overrideAttrs (attrs: rec {
   # follows the versioning scheme of nixpkgs, since rapidcheck does not