about summary refs log tree commit diff
path: root/third_party/python/broadlink.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-04-25T20·38+0100
committerVincent Ambo <tazjin@google.com>2020-04-25T20·38+0100
commitb597a1c1434f90065cfaa185426fdf8bb6c7e366 (patch)
tree770d2ecc9e13bb4142a06a57827d70316181cfed /third_party/python/broadlink.nix
parent9d94a727b27016e21fe904a555a3742d3c5b1eb9 (diff)
feat(third_party/python): Vendor broadlink-python using git-subtree r/681
Diffstat (limited to 'third_party/python/broadlink.nix')
-rw-r--r--third_party/python/broadlink.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/third_party/python/broadlink.nix b/third_party/python/broadlink.nix
deleted file mode 100644
index 75db1ef2b7af..000000000000
--- a/third_party/python/broadlink.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-# Python package for controlling the Broadlink RM Pro Infrared
-# controller.
-#
-# https://github.com/mjg59/python-broadlink
-{ pkgs, lib, ... }:
-
-let
-  inherit (pkgs) fetchFromGitHub;
-  inherit (pkgs.python3Packages) buildPythonPackage cryptography;
-in buildPythonPackage (lib.fix (self: {
-  pname = "python-broadlink";
-  version = "0.13.2";
-
-  src = fetchFromGitHub {
-    owner = "mjg59";
-    repo = "python-broadlink";
-    rev = self.version;
-    sha256 = "0dwqzx294sjdc8dg1sd3z6mhll0zzsb8k0lzs63nyhm2nc9pyv6j";
-  };
-
-  propagatedBuildInputs = [ cryptography ];
-}))