about summary refs log tree commit diff
path: root/third_party/public-inbox/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-01-29T10·44+0300
committerclbot <clbot@tvl.fyi>2023-01-29T11·10+0000
commit91146b204ff7a47eb67d6fb18bbcad0e1d3bbecd (patch)
tree57308af249ccb981ec809270cf4af7a658f25baf /third_party/public-inbox/default.nix
parentb1e4d66f8330223515275888d0dc056259250a34 (diff)
feat(3p/public-inbox): always set list-id when ingesting in watch r/5775
There is a code path in public-inbox that will (under certain
conditions) set the expected list-id as derived from the recipient
mail address (so in our case depot@tvl.su -> `List-ID: depot.tvl.su`).

However, when/how this triggers seems to be particular to the code
path taken based on certain config settings. I couldn't fully figure
it out, and to be honest I don't really know Perl, and I don't think
this warrants a super-high-effort investigation.

For that reason, this patches the appropriate line in
public-inbox-watch to always trigger this code path regardless of what
is going on with the email.

I tested this locally with a public-inbox config that does *not* have
a `listid` setting set, as that just adds an additional filter which
would be a no-op in this case. All emails are ingested correctly with
List-ID set.

There might be a better place to put this in (e.g. right before the
actual mail ingestion), if a Perl expert is interested in figuring
this out and considers it relevant, feel free to send a CL.

Note that this will not update old emails. Probably.

Change-Id: I4a8a42653aa2f408a85c9301a1ee3545f0e74eed
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7946
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to '')
-rw-r--r--third_party/public-inbox/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/third_party/public-inbox/default.nix b/third_party/public-inbox/default.nix
new file mode 100644
index 0000000000..1a4b196f94
--- /dev/null
+++ b/third_party/public-inbox/default.nix
@@ -0,0 +1,9 @@
+{ pkgs, ... }:
+
+pkgs.public-inbox.overrideAttrs (old: {
+  patches = (old.patches or [ ]) ++ [
+    ./0001-feat-always-set-the-List-ID-header-even-in-watch.patch
+  ];
+
+  doCheck = false; # too slow, and nixpkgs already runs them
+})