about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-08T09·15+0200
committerclbot <clbot@tvl.fyi>2023-10-08T11·11+0000
commitd1adefc9f99fa47c4837baf9252a6d21cf273c2c (patch)
tree44dd1a1ca876db09cb6c3224f52d4cc350a6a03d /third_party/overlays/tvl.nix
parent09328c79d556c22f9b36cef8f7010bfff3f093a8 (diff)
feat(third_party/overlays): support unix domain sockets in evans r/6727
This applies a patch adding support for unix domain sockets to evans,
which was also sent upstream at
https://github.com/ktr0731/evans/pull/680.

Change-Id: I6e483ace45428a7526a200f885aa92c2de88b650
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9563
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index ec7506ee41..c88bd4d741 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -125,4 +125,12 @@ depot.nix.readTree.drvTargets {
       outputHash = "sha256-elEIWHxyY3iccprIcbQA6GWFiq/n5kozpGfw/OmoSIg=";
     });
   });
+
+  evans = super.evans.overrideAttrs (old: {
+    patches = old.patches or [ ] ++ [
+      # add support for unix domain sockets
+      # https://github.com/ktr0731/evans/pull/680
+      ./patches/evans-add-support-for-unix-domain-sockets.patch
+    ];
+  });
 }