about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-11-26T16·33+0000
committerflokli <flokli@flokli.de>2022-12-26T11·38+0000
commit2403871bed37958d4e90ad3893017ac1a2173555 (patch)
tree1b3a97e97510cf6a51cf46234b5e152a22bebc0a /third_party/overlays/tvl.nix
parent3676ce8d6dc30a5439beec4a705a416597124435 (diff)
fix(third_party/nixpkgs): add support for --bytes-as-base64 in evans r/5493
This is very helpful when calling an RPC method that accepts bytes.

Upstreamed to https://github.com/ktr0731/evans/pull/611.

Change-Id: Ibdaa1e3ff2aed9c86816e81de6f7652042c9fb11
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7436
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 2d20264ff6..7dd9445eb0 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -92,6 +92,13 @@ in
     };
   });
 
+  # `Call $methodName --bytes-as-base64` support for evans
+  evans = super.evans.overrideAttrs (old: {
+    patches = old.patches or [ ] ++ [
+      ./patches/evans-add-support-for-bytes-as-base64.patch
+    ];
+  });
+
   # nix-serve does not work with nix 2.4
   # https://github.com/edolstra/nix-serve/issues/28
   nix-serve = super.nix-serve.override { nix = super.nix_2_3; };