about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2023-02-18T20·04+0100
committersterni <sternenseemann@systemli.org>2023-03-02T14·35+0000
commit0b64577702ca7e412bb2af4af7af9e33efc5c0f5 (patch)
treef73b1e92647aeb0456c53e8d6f5534770886ac95 /third_party/overlays/tvl.nix
parentde3eedff9be7e8bd1f6cc28ab51c7d54e0d59e9f (diff)
chore(3p/sources): Bump channels & overlays r/5866
* //3p/sources: temporarily switch to nixos-unstable-small, since it
  includes:

  - evans update we are interested in, allowing us to drop our evans
    patches.
  - awscli2 update that unbreaks //users/grfn

* //3p/overlays/tvl:

  - drop evans patches
  - update tdlib to 1.8.11 to make tazjin's emacs happy
  - drop obsolete mullvad workaround

* //users/grfn/keyboard: disable -Werror for array-bounds warnings.
  Seems like a non-trivial job to resolve the warning properly,
  hopefully GCC 12 still generates the same working code as GCC 11 used
  to.

* //users/grfn/system/home: remove yubikey-manager-qt.
  Yubico can't seem to keep that on pace with yubikey-manager. It
  requires a <5 version of the latter which is incompatible with the
  recently released cryptography >= 39.

* //3p/gerrit: update changed FOD hash for the fetch step

Change-Id: I590ab996247e69b0ab5059cd173840ef4ebfe939
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8133
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: sterni <sternenseemann@systemli.org>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix22
1 files changed, 9 insertions, 13 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 60f6360a2c..950c01798f 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -45,12 +45,15 @@ depot.nix.readTree.drvTargets {
     ];
   });
 
-  # Apply workaround from https://github.com/NixOS/nixpkgs/pull/211469
-  # until it hits the nixos-unstable channel
-  mullvad = super.mullvad.overrideAttrs (old: {
-    nativeBuildInputs = old.nativeBuildInputs ++ [
-      self.buildPackages.git
-    ];
+  # Too match telega in emacs-overlay or wherever
+  tdlib = super.tdlib.overrideAttrs (_: {
+    version = "1.8.11";
+    src = self.fetchFromGitHub {
+      owner = "tdlib";
+      repo = "td";
+      rev = "1543c41f3411bd6aa74713c8aba4e93fa8d952c7";
+      sha256 = "0qw3a2wh5hfad0m4ixywh5p2mvyprkw982jb7n4sqxdvwc0xfcgq";
+    };
   });
 
   home-manager = super.home-manager.overrideAttrs (_: {
@@ -100,13 +103,6 @@ depot.nix.readTree.drvTargets {
     };
   });
 
-  # `Call $methodName --bytes-as-base64` support for evans
-  evans = super.evans.overrideAttrs (old: {
-    patches = old.patches or [ ] ++ [
-      ./patches/evans-add-support-for-bytes-as-base64.patch
-    ];
-  });
-
   # nix-serve does not work with nix 2.4
   # https://github.com/edolstra/nix-serve/issues/28
   nix-serve = super.nix-serve.override { nix = super.nix_2_3; };