about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-07-02T09·18+0200
committerclbot <clbot@tvl.fyi>2022-07-03T14·54+0000
commit255750471b2830668352f5815932d86aec8994bb (patch)
treed516bb3ecacdd495daefb9d87779040b6c7fa878 /third_party/overlays/tvl.nix
parent46f908c3c1d6049c3aa944e2a1086fea252f3b8e (diff)
chore(3p/overlays): bump Nix fork r/4271
This includes a small fix relating to string configureFlags being
deprecated, silencing a warning during eval.

Change-Id: I9528a5554dbc56d4d3f2a60edcb7de338ca6adc0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5911
Tested-by: BuildkiteCI
Autosubmit: sterni <sternenseemann@systemli.org>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to '')
-rw-r--r--third_party/overlays/tvl.nix18
1 files changed, 11 insertions, 7 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 59c9ecf643..9bb88dc2be 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -6,14 +6,18 @@ self: super:
 let
   # Rollback Nix to a stable version (2.3) with backports for
   # build-user problems applied.
-  nixSrc = self.fetchFromGitHub
-    {
-      owner = "tvlfyi";
-      repo = "nix";
+  nixSrc =
+    let
       # branch 2.3-backport-await-users
-      rev = "880a62b08443a6baa55dab027b69bb8b1551a588";
-      hash = "sha256:0jnwrzxh04d0pyhx4n8fg4w1w6ak48byl5k2i8j7fk4h9vd9649k";
-    } // { revCount = 0; shortRev = "880a62b0"; };
+      rev = "4510dbc8a6802902cbab6444134659548fffb9b0";
+    in
+    self.fetchFromGitHub
+      {
+        owner = "tvlfyi";
+        repo = "nix";
+        inherit rev;
+        hash = "sha256:0vg2xzwc8q1sw20b26qbyd4flnws8668yhi1cg2h6z3jb3wamhr5";
+      } // { revCount = 0; shortRev = builtins.substring 0 7 rev; };
 in
 {
   nix = (import "${nixSrc}/release.nix" {