about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-06-26T09·59+0200
committerclbot <clbot@tvl.fyi>2022-06-27T14·18+0000
commitd8ccb3b9e17f8c489255478ee87de739a64b564a (patch)
treec372000bdaf40b93f1a4585c250fd1c46fba6bc2 /third_party/overlays/tvl.nix
parent1094306aa95476a16f28083d4e903bb3e5c2b3dc (diff)
chore(3p/sources): Bump channels & overlays r/4255
* //3p/nixpkgs: awscli2 has been fixed in unstable

* //3p/overlays: git now has separateDebugInfo = true; so we need to
  work around a bug in srcOnly until the corresponding fix is merged.

* //3p/overlays: upgrade tdlib to match telega in depot.

Change-Id: Idb79f2844e6a156aa83451dd57a5ac624abb0dfc
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5894
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index b2ef0eee3e..59c9ecf643 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -56,6 +56,19 @@ in
     })
   );
 
+  # Upgrade to match telega in emacs-overlay
+  # TODO(tazjin): ugrade tdlib (+ telega?!) in nixpkgs
+  tdlib = assert super.tdlib.version == "1.8.3";
+    super.tdlib.overrideAttrs (old: {
+      version = "1.8.4";
+      src = self.fetchFromGitHub {
+        owner = "tdlib";
+        repo = "td";
+        rev = "7eabd8ca60de025e45e99d4e5edd39f4ebd9467e";
+        sha256 = "1chs0ibghjj275v9arsn3k68ppblpm7ysqk0za9kya5vdnldlld5";
+      };
+    });
+
   # dottime support for notmuch
   notmuch = super.notmuch.overrideAttrs (old: {
     passthru = old.passthru // {
@@ -67,6 +80,13 @@ in
   # https://github.com/edolstra/nix-serve/issues/28
   nix-serve = super.nix-serve.override { nix = super.nix_2_3; };
 
+  # Workaround for srcOnly with separateDebugInfo until
+  # https://github.com/NixOS/nixpkgs/pull/179170 is merged.
+  srcOnly = args: (super.srcOnly args).overrideAttrs (_: {
+    outputs = [ "out" ];
+    separateDebugInfo = false;
+  });
+
   # Avoid builds of mkShell derivations in CI.
   mkShell = super.lib.makeOverridable (args: (super.mkShell args).overrideAttrs (_: {
     passthru = {