about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-03-30T11·12+0200
committersterni <sternenseemann@systemli.org>2022-03-31T16·24+0000
commitb4b0008180587be53b8a4364ced82fa5def930cb (patch)
treec723829c0c1678d0c16943aab03390b086c9cb22 /third_party/overlays/tvl.nix
parent017238a1be6704b5c33aa8c2aff1bb1b038e5177 (diff)
chore(3p/sources): Bump channels & overlays r/3928
* //3p/overlays: add workaround for broken URL in current channel.
  The added assert should fire as soon as the fix lands in channels
  as a reminder to clean it up.

Change-Id: I3014fbacec5f8933bb0c055a065c5ff2935b131b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5425
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 4cd2bd3ef5..a51035d0c6 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -74,4 +74,22 @@ self: super: {
       outputHash = "10if2lmv8d95j3walq3ggx3y423yfy4yl9vplw3apd0s671bly8b";
     });
   });
+
+  # Temporary workaround until the following commit is in channels:
+  # https://github.com/nixos/nixpkgs/commit/5819b99350d7ac6e20f91adce38e7bb22e4d6fc4
+  ocamlPackages = super.ocamlPackages.overrideScope' (oself: osuper: {
+    uutf =
+      let
+        expectedUrls = [
+          "https://erratique.ch/software/uutf/releases/uutf-${osuper.uutf.version}.tbz"
+        ];
+      in
+      assert osuper.uutf.src.urls != expectedUrls;
+      osuper.uutf.overrideAttrs (old: {
+        src = self.fetchurl {
+          urls = expectedUrls;
+          sha256 = old.src.outputHash;
+        };
+      });
+  });
 }