about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-04-26T13·32+0200
committersterni <sternenseemann@systemli.org>2022-04-26T19·16+0000
commit574d33a2ded4fc36fd0b63fa70e44d9ab378da47 (patch)
tree6337ca959203f9ad6bd694708558b2d8b5196181 /third_party/overlays/tvl.nix
parent96aea320846d3d0d61e9e00d85f58a3efe3f9f82 (diff)
chore(3p/sources): Bump channels & overlays r/3992
* //3p/farmhash: drop, as it is unused and started to fail

* //3p/overlays/tvl:

  - patch barrier to work with gcc 11

  - disable outdated test suite for python38Packages.backports-zoneinfo
    which still assumes zoneinfo 2020a.

* //3p/overlays/haskell: patch generic-arbitrary to avoid neg resizes

* //users/grfn/achilles: disable CI due to linking trouble (ugh).

* //users/grfn/system/home/games: Disable DFHack for dwarf fortress as
  it's now failing to build

Refs: ENG-328
Change-Id: I4e1ee8fd9525d4868b82f9bad8ca5f09e7fdb9d0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5506
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 9dee001ba8..9b4bc2db39 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -98,4 +98,26 @@ in
       sha256 = "07qa2qkbjczj3d0m03jpw85hfj35cbjm48xhifz3viy4khjw88vl";
     };
   });
+
+  # Fix compilation with GCC 11. Can be removed when
+  # https://github.com/NixOS/nixpkgs/pull/170157 lands in channels.
+  barrier = super.barrier.overrideAttrs (old: {
+    patches = old.patches or [ ] ++ [
+      (self.fetchpatch {
+        name = "barrier-gcc-11.patch";
+        url = "https://github.com/debauchee/barrier/commit/4b12265ae5d324b942698a3177e1d8b1749414d7.patch";
+        sha256 = "02a1hm07xgbs4d3529r2yj9vgxn1mix4y367hyw5h11kpczk2cva";
+      })
+    ];
+  });
+
+  python38 = super.python38.override {
+    packageOverrides = pySelf: pySuper: {
+      backports-zoneinfo = pySuper.backports-zoneinfo.overridePythonAttrs (_: {
+        # Outdated test-data, see https://github.com/pganssle/zoneinfo/pull/115
+        # Can be dropped when https://github.com/NixOS/nixpkgs/pull/170450 lands.
+        doCheck = false;
+      });
+    };
+  };
 }