about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-08-04T14·49+0300
committertazjin <mail@tazj.in>2021-08-08T01·28+0000
commite7de89e06aad3ccb83eb4085be82449d8f81f56c (patch)
treec5dce560371a8d2a1c4d500dfcdf593b062c50a0 /third_party/overlays/tvl.nix
parent2e30f0d4f556d71a84881e90f4feff15d78b003f (diff)
chore(3p/nixpkgs): Bump nixpkgs channels to 2021-08-04 r/2710
I used //tools/depot-nixpkgs-update for this - thanks again, sterni!

Included fixes:

* temporary workaround for building notmuch python package, fixed in
  upstream already (but channel hasn't advanced there)
* Disable fprintd in grfn.system.yeren, as the fprintd-tod package
  currently has a version mismatch in nixpkgs

Co-authored-by: Griffin Smith <grfn@gws.fyi>
Change-Id: If6d71b08ace9db57daadfe3b69b9cd4aec6a5a4e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3274
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 3482b7416b..7c7c8ea06a 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -28,4 +28,12 @@ self: super: {
       tvlPackages = depot.tools.emacs-pkgs // depot.third_party.emacs;
     })
   );
+
+  # Temporary fix for python3Packages.notmuch
+  # See https://github.com/NixOS/nixpkgs/pull/132592/
+  notmuch = super.notmuch.overrideAttrs(old: {
+    passthru = old.passthru // {
+      pythonSourceRoot = "notmuch-${old.version}/bindings/python";
+    };
+  });
 }