about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-31T12·45+0200
committerflokli <flokli@flokli.de>2023-11-02T09·32+0000
commitceca00a866f7e02b5c9c8d61cd522ea265a6eb19 (patch)
tree9a991f9f8acb10ec76a80cf29a2a445622dbdb1c /third_party/overlays/tvl.nix
parent5a0ae8312c58fb67371c3c5961a39b9a5f9c87e6 (diff)
chore(third_party/crate2nix): apply patches to fix cross r/6922
Together with temporarily pointing nixpkgs past
b10994c38c61038970a19fa60bfbec21a61755cc, this now fixes cross-
compilation for tvix.

This incorporates the changes proposed in https://cl.tvl.fyi/9888 and
https://cl.tvl.fyi/9889, but by fixing it in crate2nix, and using the
(re-)generated version of it.

Changes were sent upstream at
https://github.com/nix-community/crate2nix/pull/309,
this pulls in a minimal patch for now.

Change-Id: I70bb6f003bbc3e89de9c4eb4985ea4708ac3a9fd
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9890
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 124756fd18..94c2fbb509 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -108,12 +108,15 @@ depot.nix.readTree.drvTargets {
     };
   }));
 
-  # Apply a patch to run tests in debug, not release mode.
   crate2nix = super.crate2nix.overrideAttrs (old: rec {
     patches = old.patches ++ [
       # run tests in debug mode, not release mode
       # https://github.com/nix-community/crate2nix/pull/301
       ./patches/crate2nix-tests-debug.patch
+
+      # https://github.com/nix-community/crate2nix/pull/309
+      ./patches/crate2nix-take-lndir-from-buildPackages.patch
+      ./patches/crate2nix-skip-running-tests-when-cross-compiling.patch
     ];
   });