about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-11-03T15·32+0100
committersterni <sternenseemann@systemli.org>2022-11-03T23·08+0000
commit2de80c8c330fa4286f0fdbad129e2c66ecabaa5d (patch)
tree04086dcb396c56c79281489ced6d7ec55423b4e7 /third_party/overlays/tvl.nix
parent57cf952ea98db70fcf50ec31e1c1057562b0a1df (diff)
fix(3p/overlays/tvl): fix nvd with Nix 2.3 r/5233
If more of these issues crop up, we should consider making a patch for
our Nix fork that ignores the --experimental-features flag.

Change-Id: If146804f2c9f9375f2035985a6fd99f72b0fdcc7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7165
Autosubmit: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 4683bce9db..80f6f04fcf 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -35,6 +35,12 @@ in
 
   nix_latest = super.nix;
 
+  nvd = super.nvd.overrideAttrs (old: {
+    patches = old.patches or [ ] ++ [
+      ./patches/nvd-nix-2.3.patch
+    ];
+  });
+
   home-manager = super.home-manager.overrideAttrs (_: {
     src = depot.third_party.sources.home-manager;
     version = "git-"