about summary refs log tree commit diff
path: root/third_party/overlays/haskell/extra-pkgs/pa-run-command-0.1.0.0.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2023-06-19T22·22+0200
committerProfpatsch <mail@profpatsch.de>2023-07-14T08·03+0000
commit98e38339f2b753f5d19ec9ba84b095a189f97e84 (patch)
tree697c98ac5f2633605b00a1e5c0a7a2ac69ec892b /third_party/overlays/haskell/extra-pkgs/pa-run-command-0.1.0.0.nix
parent07b976ccd89cc8a4b5d0624ee2223d64add4615d (diff)
feat(users/Profpatsch/whatcd-resolver): add initial redacted API r/6414
Change-Id: I3143a932646d61b7661df4e4da4edf24a360f6cc
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8833
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/overlays/haskell/extra-pkgs/pa-run-command-0.1.0.0.nix')
-rw-r--r--third_party/overlays/haskell/extra-pkgs/pa-run-command-0.1.0.0.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/overlays/haskell/extra-pkgs/pa-run-command-0.1.0.0.nix b/third_party/overlays/haskell/extra-pkgs/pa-run-command-0.1.0.0.nix
new file mode 100644
index 000000000000..b12eb5efbf5f
--- /dev/null
+++ b/third_party/overlays/haskell/extra-pkgs/pa-run-command-0.1.0.0.nix
@@ -0,0 +1,25 @@
+{ mkDerivation
+, base
+, bytestring
+, lib
+, monad-logger
+, pa-prelude
+, text
+, typed-process
+}:
+mkDerivation {
+  pname = "pa-run-command";
+  version = "0.1.0.0";
+  sha256 = "37837e0cddedc9b615063f0357115739c53b5dcb8af82ce86a95a3a5c88c29a3";
+  libraryHaskellDepends = [
+    base
+    bytestring
+    monad-logger
+    pa-prelude
+    text
+    typed-process
+  ];
+  homepage = "https://github.com/possehl-analytics/pa-hackage";
+  description = "Helper functions for spawning subprocesses";
+  license = lib.licenses.bsd3;
+}