about summary refs log tree commit diff
path: root/third_party/overlays/haskell/extra-pkgs/pa-prelude.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2023-10-15T18·16+0200
committerclbot <clbot@tvl.fyi>2023-10-15T18·58+0000
commit0a98f8ec3b7c98b53e9bb1203cb5b63ecdc068ce (patch)
treed30e5a18cf121605767d5905abf50807ca7be6db /third_party/overlays/haskell/extra-pkgs/pa-prelude.nix
parent9aafbe8d952d6e31fa7273572f00ec79d9d15554 (diff)
chore(third_party/haskell): update pa packages r/6816
Change-Id: I8abcb479b0f5c0bd6ed1abc3c9618c2362ff835a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9740
Autosubmit: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'third_party/overlays/haskell/extra-pkgs/pa-prelude.nix')
-rw-r--r--third_party/overlays/haskell/extra-pkgs/pa-prelude.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/overlays/haskell/extra-pkgs/pa-prelude.nix b/third_party/overlays/haskell/extra-pkgs/pa-prelude.nix
new file mode 100644
index 000000000000..17e1996ab602
--- /dev/null
+++ b/third_party/overlays/haskell/extra-pkgs/pa-prelude.nix
@@ -0,0 +1,43 @@
+{ mkDerivation
+, base
+, bytestring
+, containers
+, error
+, exceptions
+, lib
+, mtl
+, profunctors
+, PyF
+, scientific
+, semigroupoids
+, template-haskell
+, text
+, these
+, validation-selective
+, vector
+}:
+mkDerivation {
+  pname = "pa-prelude";
+  version = "0.2.0.0";
+  sha256 = "68015f7c19e9c618fc04e2516baccfce52af24efb9ca1480162c9ea0aef7f301";
+  libraryHaskellDepends = [
+    base
+    bytestring
+    containers
+    error
+    exceptions
+    mtl
+    profunctors
+    PyF
+    scientific
+    semigroupoids
+    template-haskell
+    text
+    these
+    validation-selective
+    vector
+  ];
+  homepage = "https://github.com/possehl-analytics/pa-hackage";
+  description = "The Possehl Analytics Prelude";
+  license = lib.licenses.bsd3;
+}