about summary refs log tree commit diff
path: root/third_party/nix/tests/search.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/tests/search.nix
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/tests/search.nix')
-rw-r--r--third_party/nix/tests/search.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/third_party/nix/tests/search.nix b/third_party/nix/tests/search.nix
deleted file mode 100644
index fea6e7a7a6..0000000000
--- a/third_party/nix/tests/search.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-with import ./config.nix;
-
-{
-  hello = mkDerivation rec {
-    name = "hello-${version}";
-    version = "0.1";
-    buildCommand = "touch $out";
-    meta.description = "Empty file";
-  };
-  foo = mkDerivation rec {
-    name = "foo-5";
-    buildCommand = ''
-      mkdir -p $out
-      echo ${name} > $out/${name}
-    '';
-  };
-  bar = mkDerivation rec {
-    name = "bar-3";
-    buildCommand = ''
-      echo "Does not build successfully"
-      exit 1
-    '';
-    meta.description = "broken bar";
-  };
-}