about summary refs log tree commit diff
path: root/third_party/nix/tests/lang/eval-okay-strings-as-attrs-names.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-18T23·25+0100
committertazjin <mail@tazj.in>2020-07-19T00·49+0000
commit70633a30583f8df01809e64696f6743810b13a93 (patch)
treeede411f6785ba1176d4159d79e3bb59b0db5c726 /third_party/nix/tests/lang/eval-okay-strings-as-attrs-names.nix
parent7010d4dc8641b350d33cf2634638b7cba6c93ae2 (diff)
chore(3p/nix/tests): Move language test files to src/tests r/1387
These files will be integrated into the evaluator unit tests instead
of running separately via a shell script.

Change-Id: I1d229e73b1d862777f5108c86891689900edefbe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1275
Tested-by: BuildkiteCI
Reviewed-by: Kane York <rikingcoding@gmail.com>
Reviewed-by: isomer <isomer@tvl.fyi>
Diffstat (limited to 'third_party/nix/tests/lang/eval-okay-strings-as-attrs-names.nix')
-rw-r--r--third_party/nix/tests/lang/eval-okay-strings-as-attrs-names.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/third_party/nix/tests/lang/eval-okay-strings-as-attrs-names.nix b/third_party/nix/tests/lang/eval-okay-strings-as-attrs-names.nix
deleted file mode 100644
index 5e40928dbe31..000000000000
--- a/third_party/nix/tests/lang/eval-okay-strings-as-attrs-names.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-let
-
-  attr = {
-    "key 1" = "test";
-    "key 2" = "caseok";
-  };
-
-  t1 = builtins.getAttr "key 1" attr;
-  t2 = attr."key 2";
-  t3 = attr ? "key 1";
-  t4 = builtins.attrNames { inherit (attr) "key 1"; };
-
-  # This is permitted, but there is currently no way to reference this
-  # variable.
-  "foo bar" = 1;
-
-in t1 == "test"
-   && t2 == "caseok"
-   && t3 == true
-   && t4 == ["key 1"]