about summary refs log tree commit diff
path: root/third_party/nix/tests/lang/eval-okay-delayed-with.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-18T23·25+0100
committertazjin <mail@tazj.in>2020-07-19T00·49+0000
commit70633a30583f8df01809e64696f6743810b13a93 (patch)
treeede411f6785ba1176d4159d79e3bb59b0db5c726 /third_party/nix/tests/lang/eval-okay-delayed-with.nix
parent7010d4dc8641b350d33cf2634638b7cba6c93ae2 (diff)
chore(3p/nix/tests): Move language test files to src/tests r/1387
These files will be integrated into the evaluator unit tests instead
of running separately via a shell script.

Change-Id: I1d229e73b1d862777f5108c86891689900edefbe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1275
Tested-by: BuildkiteCI
Reviewed-by: Kane York <rikingcoding@gmail.com>
Reviewed-by: isomer <isomer@tvl.fyi>
Diffstat (limited to 'third_party/nix/tests/lang/eval-okay-delayed-with.nix')
-rw-r--r--third_party/nix/tests/lang/eval-okay-delayed-with.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/third_party/nix/tests/lang/eval-okay-delayed-with.nix b/third_party/nix/tests/lang/eval-okay-delayed-with.nix
deleted file mode 100644
index 3fb023e1cd..0000000000
--- a/third_party/nix/tests/lang/eval-okay-delayed-with.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-let
-
-  pkgs_ = with pkgs; {
-    a = derivation {
-      name = "a";
-      system = builtins.currentSystem;
-      builder = "/bin/sh";
-      args = [ "-c" "touch $out" ];
-      inherit b;
-    };
-
-    b = derivation {
-      name = "b";
-      system = builtins.currentSystem;
-      builder = "/bin/sh";
-      args = [ "-c" "touch $out" ];
-      inherit a;
-    };
-
-    c = b;
-  };
-
-  packageOverrides = pkgs: with pkgs; {
-    b = derivation (b.drvAttrs // { name = "${b.name}-overridden"; });
-  };
-
-  pkgs = pkgs_ // (packageOverrides pkgs_);
-
-in "${pkgs.a.b.name} ${pkgs.c.name} ${pkgs.b.a.name}"