about summary refs log tree commit diff
path: root/third_party/nix/tests/check-reqs.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/tests/check-reqs.nix
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/tests/check-reqs.nix')
-rw-r--r--third_party/nix/tests/check-reqs.nix57
1 files changed, 0 insertions, 57 deletions
diff --git a/third_party/nix/tests/check-reqs.nix b/third_party/nix/tests/check-reqs.nix
deleted file mode 100644
index 41436cb48e..0000000000
--- a/third_party/nix/tests/check-reqs.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-with import ./config.nix;
-
-rec {
-  dep1 = mkDerivation {
-    name = "check-reqs-dep1";
-    builder = builtins.toFile "builder.sh" "mkdir $out; touch $out/file1";
-  };
-
-  dep2 = mkDerivation {
-    name = "check-reqs-dep2";
-    builder = builtins.toFile "builder.sh" "mkdir $out; touch $out/file2";
-  };
-
-  deps = mkDerivation {
-    name = "check-reqs-deps";
-    dep1 = dep1;
-    dep2 = dep2;
-    builder = builtins.toFile "builder.sh" ''
-      mkdir $out
-      ln -s $dep1/file1 $out/file1
-      ln -s $dep2/file2 $out/file2
-    '';
-  };
-
-  makeTest = nr: allowreqs: mkDerivation {
-    name = "check-reqs-" + toString nr;
-    inherit deps;
-    builder = builtins.toFile "builder.sh" ''
-      mkdir $out
-      ln -s $deps $out/depdir1
-    '';
-    allowedRequisites = allowreqs;
-  };
-
-  # When specifying all the requisites, the build succeeds.
-  test1 = makeTest 1 [ dep1 dep2 deps ];
-
-  # But missing anything it fails.
-  test2 = makeTest 2 [ dep2 deps ];
-  test3 = makeTest 3 [ dep1 deps ];
-  test4 = makeTest 4 [ deps ];
-  test5 = makeTest 5 [];
-
-  test6 = mkDerivation {
-    name = "check-reqs";
-    inherit deps;
-    builder = builtins.toFile "builder.sh" "mkdir $out; ln -s $deps $out/depdir1";
-    disallowedRequisites = [dep1];
-  };
-
-  test7 = mkDerivation {
-    name = "check-reqs";
-    inherit deps;
-    builder = builtins.toFile "builder.sh" "mkdir $out; ln -s $deps $out/depdir1";
-    disallowedRequisites = [test1];
-  };
-}