about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/evalstore-okay-context.nix
diff options
context:
space:
mode:
authorKane York <kanepyork@gmail.com>2020-08-15T02·04-0700
committerkanepyork <rikingcoding@gmail.com>2020-08-18T03·58+0000
commitb76cd7253a1d0e6ce2260071c375eae7a8141468 (patch)
tree51da97b5f2dd18dd3f2378487afd6734f8843e1a /third_party/nix/src/tests/lang/evalstore-okay-context.nix
parentfea4df560bdb9a14c3ea6d45aaad26a6a24d6ce5 (diff)
feat(tvix): Re-enable language tests that needed a store r/1673
Now that we have access to a store in tests, we can enable the tests that needed a store.

Additionally, move the expected output files for disabled tests into the disabled folder.

Change-Id: I2492d49d43b93c7c9b0463e4d3d2855a5a51365d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1758
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/nix/src/tests/lang/evalstore-okay-context.nix')
-rw-r--r--third_party/nix/src/tests/lang/evalstore-okay-context.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/lang/evalstore-okay-context.nix b/third_party/nix/src/tests/lang/evalstore-okay-context.nix
new file mode 100644
index 000000000000..90f82abe1c36
--- /dev/null
+++ b/third_party/nix/src/tests/lang/evalstore-okay-context.nix
@@ -0,0 +1,6 @@
+let s = "foo ${builtins.substring 33 100 (baseNameOf "${./evalstore-okay-context.nix}")} bar";
+in
+  if s != "foo evalstore-okay-context.nix bar"
+  then abort "context not discarded"
+  else builtins.unsafeDiscardStringContext s
+