about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/evalstore-okay-context-introspection.nix
diff options
context:
space:
mode:
authorKane York <kanepyork@gmail.com>2020-08-15T02·04-0700
committerkanepyork <rikingcoding@gmail.com>2020-08-18T03·58+0000
commitb76cd7253a1d0e6ce2260071c375eae7a8141468 (patch)
tree51da97b5f2dd18dd3f2378487afd6734f8843e1a /third_party/nix/src/tests/lang/evalstore-okay-context-introspection.nix
parentfea4df560bdb9a14c3ea6d45aaad26a6a24d6ce5 (diff)
feat(tvix): Re-enable language tests that needed a store r/1673
Now that we have access to a store in tests, we can enable the tests that needed a store.

Additionally, move the expected output files for disabled tests into the disabled folder.

Change-Id: I2492d49d43b93c7c9b0463e4d3d2855a5a51365d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1758
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/nix/src/tests/lang/evalstore-okay-context-introspection.nix')
-rw-r--r--third_party/nix/src/tests/lang/evalstore-okay-context-introspection.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/lang/evalstore-okay-context-introspection.nix b/third_party/nix/src/tests/lang/evalstore-okay-context-introspection.nix
new file mode 100644
index 000000000000..d11aad38c726
--- /dev/null
+++ b/third_party/nix/src/tests/lang/evalstore-okay-context-introspection.nix
@@ -0,0 +1,24 @@
+let
+  drv = derivation {
+    name = "fail";
+    builder = "/bin/false";
+    system = "x86_64-linux";
+    outputs = [ "out" "foo" ];
+  };
+
+  path = "${./evalstore-okay-context-introspection.nix}";
+
+  desired-context = {
+    "${builtins.unsafeDiscardStringContext path}" = {
+      path = true;
+    };
+    "${builtins.unsafeDiscardStringContext drv.drvPath}" = {
+      outputs = [ "foo" "out" ];
+      allOutputs = true;
+    };
+  };
+
+  legit-context = builtins.getContext "${path}${drv.outPath}${drv.foo.outPath}${drv.drvPath}";
+
+  constructed-context = builtins.getContext (builtins.appendContext "" desired-context);
+in legit-context == constructed-context