about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix b/third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix
deleted file mode 100644
index 5e40928dbe..0000000000
--- a/third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-let
-
-  attr = {
-    "key 1" = "test";
-    "key 2" = "caseok";
-  };
-
-  t1 = builtins.getAttr "key 1" attr;
-  t2 = attr."key 2";
-  t3 = attr ? "key 1";
-  t4 = builtins.attrNames { inherit (attr) "key 1"; };
-
-  # This is permitted, but there is currently no way to reference this
-  # variable.
-  "foo bar" = 1;
-
-in t1 == "test"
-   && t2 == "caseok"
-   && t3 == true
-   && t4 == ["key 1"]