about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-regex-match.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-18T23·25+0100
committertazjin <mail@tazj.in>2020-07-19T00·49+0000
commit70633a30583f8df01809e64696f6743810b13a93 (patch)
treeede411f6785ba1176d4159d79e3bb59b0db5c726 /third_party/nix/src/tests/lang/eval-okay-regex-match.nix
parent7010d4dc8641b350d33cf2634638b7cba6c93ae2 (diff)
chore(3p/nix/tests): Move language test files to src/tests r/1387
These files will be integrated into the evaluator unit tests instead
of running separately via a shell script.

Change-Id: I1d229e73b1d862777f5108c86891689900edefbe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1275
Tested-by: BuildkiteCI
Reviewed-by: Kane York <rikingcoding@gmail.com>
Reviewed-by: isomer <isomer@tvl.fyi>
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-regex-match.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-regex-match.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-regex-match.nix b/third_party/nix/src/tests/lang/eval-okay-regex-match.nix
new file mode 100644
index 0000000000..273e259071
--- /dev/null
+++ b/third_party/nix/src/tests/lang/eval-okay-regex-match.nix
@@ -0,0 +1,29 @@
+with builtins;
+
+let
+
+  matches = pat: s: match pat s != null;
+
+  splitFN = match "((.*)/)?([^/]*)\\.(nix|cc)";
+
+in
+
+assert  matches "foobar" "foobar";
+assert  matches "fo*" "f";
+assert !matches "fo+" "f";
+assert  matches "fo*" "fo";
+assert  matches "fo*" "foo";
+assert  matches "fo+" "foo";
+assert  matches "fo{1,2}" "foo";
+assert !matches "fo{1,2}" "fooo";
+assert !matches "fo*" "foobar";
+assert  matches "[[:space:]]+([^[:space:]]+)[[:space:]]+" "  foo   ";
+assert !matches "[[:space:]]+([[:upper:]]+)[[:space:]]+" "  foo   ";
+
+assert match "(.*)\\.nix" "foobar.nix" == [ "foobar" ];
+assert match "[[:space:]]+([[:upper:]]+)[[:space:]]+" "  FOO   " == [ "FOO" ];
+
+assert splitFN "/path/to/foobar.nix" == [ "/path/to/" "/path/to" "foobar" "nix" ];
+assert splitFN "foobar.cc" == [ null null "foobar" "cc" ];
+
+true