about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-18T23·25+0100
committertazjin <mail@tazj.in>2020-07-19T00·49+0000
commit70633a30583f8df01809e64696f6743810b13a93 (patch)
treeede411f6785ba1176d4159d79e3bb59b0db5c726 /third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix
parent7010d4dc8641b350d33cf2634638b7cba6c93ae2 (diff)
chore(3p/nix/tests): Move language test files to src/tests r/1387
These files will be integrated into the evaluator unit tests instead
of running separately via a shell script.

Change-Id: I1d229e73b1d862777f5108c86891689900edefbe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1275
Tested-by: BuildkiteCI
Reviewed-by: Kane York <rikingcoding@gmail.com>
Reviewed-by: isomer <isomer@tvl.fyi>
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix b/third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix
new file mode 100644
index 0000000000..4186e029b5
--- /dev/null
+++ b/third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix
@@ -0,0 +1,11 @@
+# this test shows how to use listToAttrs and that evaluation is still lazy (throw isn't called)
+with import ./lib.nix;
+
+let 
+  asi = name: value : { inherit name value; };
+  list = [ ( asi "a" "A" ) ( asi "b" "B" ) ];
+  a = builtins.listToAttrs list;
+  b = builtins.listToAttrs ( list ++ list );
+  r = builtins.listToAttrs [ (asi "result" [ a b ]) ( asi "throw" (throw "this should not be thrown")) ];
+  x = builtins.listToAttrs [ (asi "foo" "bar") (asi "foo" "bla") ];
+in concat (map (x: x.a) r.result) + x.foo