about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-comments.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/src/tests/lang/eval-okay-comments.nix
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-comments.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-comments.nix59
1 files changed, 0 insertions, 59 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-comments.nix b/third_party/nix/src/tests/lang/eval-okay-comments.nix
deleted file mode 100644
index cb2cce218029..000000000000
--- a/third_party/nix/src/tests/lang/eval-okay-comments.nix
+++ /dev/null
@@ -1,59 +0,0 @@
-# A simple comment
-"a"+ # And another
-## A double comment
-"b"+  ## And another
-# Nested # comments #
-"c"+   # and # some # other #
-# An empty line, following here:
-
-"d"+      # and a comment not starting the line !
-
-"e"+
-/* multiline comments */
-"f" +
-/* multiline
-   comments,
-   on
-   multiple
-   lines
-*/
-"g" +
-# Small, tricky comments
-/**/ "h"+ /*/*/ "i"+ /***/ "j"+ /* /*/ "k"+ /*/* /*/ "l"+
-# Comments with an even number of ending '*' used to fail:
-"m"+
-/* */ /* **/ /* ***/ /* ****/ "n"+
-/* */ /** */ /*** */ /**** */ "o"+
-/** **/ /*** ***/ /**** ****/ "p"+
-/* * ** *** **** ***** */     "q"+
-# Random comments
-/* ***** ////// * / * / /* */ "r"+
-# Mixed comments
-/* # */
-"s"+
-# /* #
-"t"+
-# /* # */
-"u"+
-# /*********/
-"v"+
-## */*
-"w"+
-/*
- * Multiline, decorated comments
- * # This ain't a nest'd comm'nt
- */
-"x"+
-''${/** with **/"y"
-  # real
-  /* comments
-     inside ! # */
-
-  # (and empty lines)
-
-}''+          /* And a multiline comment,
-                 on the same line,
-                 after some spaces
-*/             # followed by a one-line comment
-"z"
-/* EOF */