about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-closure.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/src/tests/lang/eval-okay-closure.nix
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-closure.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-closure.nix13
1 files changed, 0 insertions, 13 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-closure.nix b/third_party/nix/src/tests/lang/eval-okay-closure.nix
deleted file mode 100644
index cccd4dc35730..000000000000
--- a/third_party/nix/src/tests/lang/eval-okay-closure.nix
+++ /dev/null
@@ -1,13 +0,0 @@
-let
-
-  closure = builtins.genericClosure {
-    startSet = [{key = 80;}];
-    operator = {key, foo ? false}:
-      if builtins.lessThan key 0
-      then []
-      else [{key = builtins.sub key 9;} {key = builtins.sub key 13; foo = true;}];
-  };
-
-  sort = (import ./lib.nix).sortBy (a: b: builtins.lessThan a.key b.key);
-
-in sort closure