about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-arithmetic.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/src/tests/lang/eval-okay-arithmetic.nix
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-arithmetic.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-arithmetic.nix59
1 files changed, 0 insertions, 59 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-arithmetic.nix b/third_party/nix/src/tests/lang/eval-okay-arithmetic.nix
deleted file mode 100644
index 7e9e6a0b66..0000000000
--- a/third_party/nix/src/tests/lang/eval-okay-arithmetic.nix
+++ /dev/null
@@ -1,59 +0,0 @@
-with import ./lib.nix;
-
-let {
-
-  /* Supposedly tail recursive version:
-
-  range_ = accum: first: last:
-    if first == last then ([first] ++ accum)
-    else range_ ([first] ++ accum) (builtins.add first 1) last;
-
-  range = range_ [];
-  */
-
-  x = 12;
-
-  err = abort "urgh";
-
-  body = sum
-    [ (sum (range 1 50))
-      (123 + 456)
-      (0 + -10 + -(-11) + -x)
-      (10 - 7 - -2)
-      (10 - (6 - -1))
-      (10 - 1 + 2)
-      (3 * 4 * 5)
-      (56088 / 123 / 2)
-      (3 + 4 * const 5 0 - 6 / id 2)
-
-      (builtins.bitAnd 12 10) # 0b1100 & 0b1010 =  8
-      (builtins.bitOr  12 10) # 0b1100 | 0b1010 = 14
-      (builtins.bitXor 12 10) # 0b1100 ^ 0b1010 =  6
-
-      (if 3 < 7 then 1 else err)
-      (if 7 < 3 then err else 1)
-      (if 3 < 3 then err else 1)
-
-      (if 3 <= 7 then 1 else err)
-      (if 7 <= 3 then err else 1)
-      (if 3 <= 3 then 1 else err)
-
-      (if 3 > 7 then err else 1)
-      (if 7 > 3 then 1 else err)
-      (if 3 > 3 then err else 1)
-
-      (if 3 >= 7 then err else 1)
-      (if 7 >= 3 then 1 else err)
-      (if 3 >= 3 then 1 else err)
-
-      (if 2 > 1 == 1 < 2 then 1 else err)
-      (if 1 + 2 * 3 >= 7 then 1 else err)
-      (if 1 + 2 * 3 < 7 then err else 1)
-
-      # Not integer, but so what.
-      (if "aa" < "ab" then 1 else err)
-      (if "aa" < "aa" then err else 1)
-      (if "foo" < "foobar" then 1 else err)
-    ];
-
-}