about summary refs log tree commit diff
path: root/third_party/nix/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-08-09T04·27-0400
committerglittershark <grfn@gws.fyi>2020-08-09T17·26+0000
commitd1653533a6f6f70d1d95001abf3f80665ba135e7 (patch)
tree35c29ccb38f404848eec2969862c6bd0f0671b43 /third_party/nix/src/tests/CMakeLists.txt
parentdfab786653c24b11a8e9338df29c22fd7a0c4959 (diff)
test(tvix): Cover scanForReferences in a test r/1627
Aded a few test cases covering the scanForReferences function, which had
been accidentally broken in 976a36c (which is now partially-reverted).
As part of this, since the test needed to generate hashes for store
paths, the logic in MakeStorePath to compress a sha256 hash down to 20
bytes and convert it to base32 has been extracted to a member function
on the Hash class.

Fixes: #34
Change-Id: Ie2d914688a80f42d0234d351a7cc0714fd15709e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1698
Tested-by: BuildkiteCI
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Diffstat (limited to 'third_party/nix/src/tests/CMakeLists.txt')
-rw-r--r--third_party/nix/src/tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/CMakeLists.txt b/third_party/nix/src/tests/CMakeLists.txt
index 929acc5ea6..cda8f5da84 100644
--- a/third_party/nix/src/tests/CMakeLists.txt
+++ b/third_party/nix/src/tests/CMakeLists.txt
@@ -30,6 +30,16 @@ target_link_libraries(hash_test
 
 gtest_discover_tests(hash_test)
 
+add_executable(references_test references_test.cc)
+target_link_libraries(references_test
+  nixstore
+  rapidcheck
+  rapidcheck_gtest
+  GTest::gtest_main
+)
+
+gtest_discover_tests(references_test)
+
 add_executable(store_test store_tests.cc)
 target_link_libraries(store_test
   nixstore