about summary refs log tree commit diff
path: root/third_party/nix/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorKane York <kanepyork@gmail.com>2020-08-03T13·43-0700
committerkanepyork <rikingcoding@gmail.com>2020-08-05T04·11+0000
commitffa8e7a9986260280b5a3f415f73b47a53ba25c3 (patch)
tree674a4b76b54bccd4aa479eb41bc3cf5c47795f94 /third_party/nix/src/tests/CMakeLists.txt
parent3c3527e16bf1d0bf57207dcc54975534f5252225 (diff)
feat(3p/nix): add tests for BinaryCacheStore r/1596
These tests are in preparation for factoring the Store away from libutil's Callback to absl::StatusOr.
They use the newly added MockBinaryCacheStore.

Updates: #25

Change-Id: I30c207589ec38254806ebc9a983f35668e353ae9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1595
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/nix/src/tests/CMakeLists.txt')
-rw-r--r--third_party/nix/src/tests/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/CMakeLists.txt b/third_party/nix/src/tests/CMakeLists.txt
index 33f4f774a6..929acc5ea6 100644
--- a/third_party/nix/src/tests/CMakeLists.txt
+++ b/third_party/nix/src/tests/CMakeLists.txt
@@ -30,6 +30,15 @@ target_link_libraries(hash_test
 
 gtest_discover_tests(hash_test)
 
+add_executable(store_test store_tests.cc)
+target_link_libraries(store_test
+  nixstore
+  nixstoremock
+  GTest::gtest_main
+)
+
+gtest_discover_tests(store_test)
+
 add_executable(value-to-json value-to-json.cc)
 target_link_libraries(value-to-json
   nixexpr