about summary refs log tree commit diff
path: root/third_party/nix/src/proto/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/src/proto/CMakeLists.txt
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/src/proto/CMakeLists.txt')
-rw-r--r--third_party/nix/src/proto/CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/third_party/nix/src/proto/CMakeLists.txt b/third_party/nix/src/proto/CMakeLists.txt
deleted file mode 100644
index 726ca8742f..0000000000
--- a/third_party/nix/src/proto/CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
-# -*- mode: cmake; -*-
-#
-# The proto generation happens outside of CMake and the path to the
-# generated files is passed in via the environment variable
-# $NIX_PROTO_SRCS.
-#
-# This configuration defines a library target that compiles these
-# sources and makes the headers available.
-
-add_library(nixproto SHARED)
-set_property(TARGET nixproto PROPERTY CXX_STANDARD 17)
-
-set(HEADER_FILES
-  $ENV{NIX_PROTO_SRCS}/libproto/worker.grpc.pb.h
-  $ENV{NIX_PROTO_SRCS}/libproto/worker.pb.h
-)
-
-target_sources(nixproto
-  PUBLIC
-    ${HEADER_FILES}
-
-  PRIVATE
-    $ENV{NIX_PROTO_SRCS}/libproto/worker.grpc.pb.cc
-    $ENV{NIX_PROTO_SRCS}/libproto/worker.pb.cc
-)
-
-target_link_libraries(nixproto
-  gRPC::grpc++_reflection
-  protobuf::libprotobuf
-)
-
-target_include_directories(nixproto
-  INTERFACE $ENV{NIX_PROTO_SRCS}
-)
-
-INSTALL(FILES ${HEADER_FILES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/nix/libproto)
-INSTALL(TARGETS nixproto DESTINATION ${CMAKE_INSTALL_LIBDIR})