about summary refs log tree commit diff
path: root/third_party/nix/src/nix/meson.build
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-17T19·45+0100
committerVincent Ambo <tazjin@google.com>2020-05-17T19·45+0100
commit9d865dbb1fed8da4ff471379f803814521298d16 (patch)
tree88dd9f0d9124f25c1247e4d12233e88aebb25b39 /third_party/nix/src/nix/meson.build
parentaa54512ee2fddb0ef0083e8845873363cbe5b50b (diff)
chore(3p/nix): Remove symlink setup from Meson build r/744
This belongs in the derivation itself, IMO.
Diffstat (limited to '')
-rw-r--r--third_party/nix/src/nix/meson.build75
1 files changed, 0 insertions, 75 deletions
diff --git a/third_party/nix/src/nix/meson.build b/third_party/nix/src/nix/meson.build
index be7ccb1a28..2ccda218d6 100644
--- a/third_party/nix/src/nix/meson.build
+++ b/third_party/nix/src/nix/meson.build
@@ -1,12 +1,3 @@
-# Nix exec build file
-#============================================================================
-
-
-
-
-# src files
-#============================================================================
-
 src_inc += include_directories('.')
 
 nix_src = files(
@@ -53,20 +44,6 @@ nix_src = files(
     join_paths(meson.source_root(), 'src/nix-store/graphml.cc'),
     join_paths(meson.source_root(), 'src/nix-store/nix-store.cc'))
 
-nix_ln_src = [
-    [ bindir, 'nix-build' ],
-    [ bindir, 'nix-channel' ],
-    [ bindir, 'nix-collect-garbage' ],
-    [ bindir, 'nix-copy-closure' ],
-    [ bindir, 'nix-daemon' ],
-    [ bindir, 'nix-env' ],
-    [ bindir, 'nix-hash' ],
-    [ bindir, 'nix-instantiate' ],
-    [ bindir, 'nix-prefetch-url' ],
-    [ bindir, 'nix-shell' ],
-    [ bindir, 'nix-store' ],
-    [ join_paths(libexecdir, 'nix'), 'build-remote' ]]
-
 nix_headers = files (
     join_paths(meson.source_root(), 'src/nix/command.hh'),
     join_paths(meson.source_root(), 'src/nix/legacy.hh'),
@@ -75,9 +52,6 @@ nix_headers = files (
     join_paths(meson.source_root(), 'src/nix-store/dotgraph.hh'),
     join_paths(meson.source_root(), 'src/nix-store/graphml.hh'))
 
-# dependancies
-#============================================================================
-
 nix_dep_list = [
     pthread_dep,
     libdl_dep,
@@ -85,13 +59,6 @@ nix_dep_list = [
     editline_dep,
     libsodium_dep]
 
-
-
-
-
-# Link args
-#============================================================================
-
 nix_link_list = [
     libutil_lib,
     libstore_lib,
@@ -99,28 +66,6 @@ nix_link_list = [
     libexpr_lib
 ]
 
-nix_link_args = []
-
-
-
-
-# compiler args
-#============================================================================
-
-nix_cxx_args = []
-
-
-
-
-# targets
-#============================================================================
-
-
-
-
-# build
-#============================================================================
-
 nix_bin = executable(
     'nix',
     install : true,
@@ -130,23 +75,3 @@ nix_bin = executable(
     sources : nix_src,
     link_with : nix_link_list,
     dependencies : nix_dep_list)
-
-
-# meson does not yet support installing symlink files.
-# this is a simple workaround
-foreach name : nix_ln_src
-    meson.add_install_script(
-        'ln',
-        '-sf',
-        join_paths(bindir, 'nix'),
-        name[1])
-    meson.add_install_script(
-        'cp',
-        '-r',
-        name[1],
-        join_paths(name[0], name[1]))   
-endforeach
-
-install_headers(
-    nix_headers,
-    install_dir : join_paths(includedir, 'nix'))