about summary refs log tree commit diff
path: root/third_party/nix/src/nix-daemon/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-08-03T18·05+0100
committertazjin <mail@tazj.in>2020-08-03T18·26+0000
commit1f12544179041b151f146fbb604e9af165ffe379 (patch)
treef1cba1958e25749cd9a85192c672d1ffb9aca82b /third_party/nix/src/nix-daemon/CMakeLists.txt
parent229c1ed820fe20515a69f749c38d5f9f89d20c8d (diff)
refactor(3p/nix): Build nix-daemon as a separate binary r/1569
Skips over all the monobinary stuff and moves to a separate binary for
nix-daemon.

This also replaces the flag parsing logic with absl::flags. This
causes a behaviour change for --help, which no longer tries to display
a man page but instead shows the actual command-line help.

Note: This binary no longer links to the Boehm GC.

Change-Id: Ib852e994b82f2d56e91262878c10650e656427a9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1622
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/nix/src/nix-daemon/CMakeLists.txt')
-rw-r--r--third_party/nix/src/nix-daemon/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/third_party/nix/src/nix-daemon/CMakeLists.txt b/third_party/nix/src/nix-daemon/CMakeLists.txt
new file mode 100644
index 0000000000..27a4a1254e
--- /dev/null
+++ b/third_party/nix/src/nix-daemon/CMakeLists.txt
@@ -0,0 +1,26 @@
+# -*- mode: cmake; -*-
+
+# The nix-daemon is the binary running the gRPC server component to
+# which other components of Nix talk to perform store and builder
+# operations.
+
+add_executable(nix-daemon)
+include_directories(${PROJECT_BINARY_DIR}) # for config.h
+set_property(TARGET nix-daemon PROPERTY CXX_STANDARD 17)
+
+target_sources(nix-daemon
+  PRIVATE
+    nix-daemon-proto.hh
+    nix-daemon-proto.cc
+    nix-daemon.cc
+)
+
+target_link_libraries(nix-daemon
+  nixutil
+  nixstore
+  nixmain
+  absl::flags
+  absl::flags_parse
+)
+
+install(TARGETS nix-daemon DESTINATION bin)