about summary refs log tree commit diff
path: root/third_party/nix/src/libutil/meson.build
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-25T00·19+0100
committerVincent Ambo <tazjin@google.com>2020-05-25T00·19+0100
commit98299da0fda612b42ab933c47f18163cfef5fa71 (patch)
tree78fc0f1127b5f2336d3e370f342f72f38d5a5ee2 /third_party/nix/src/libutil/meson.build
parentb371821db59d33851d521d66ba1fb126d388c00f (diff)
refactor(3p/nix/libutil): Replace string2Int & trim functions r/843
Replaces these functions with corresponding functions from Abseil,
namely absl::StripAsciiWhitespace and absl::SimpleAtoi.

In the course of doing this some minor things I encountered along the
way were also refactored.

This also changes the signatures of the various custom readFile
functions to use absl::string_view types.
Diffstat (limited to 'third_party/nix/src/libutil/meson.build')
-rw-r--r--third_party/nix/src/libutil/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/third_party/nix/src/libutil/meson.build b/third_party/nix/src/libutil/meson.build
index a6494e6eac..50043a8fad 100644
--- a/third_party/nix/src/libutil/meson.build
+++ b/third_party/nix/src/libutil/meson.build
@@ -47,7 +47,7 @@ libutil_dep_list = [
   openssl_dep,
   pthread_dep,
   libsodium_dep,
-]
+] + absl_deps
 
 libutil_link_list = []
 libutil_link_args = []