about summary refs log tree commit diff
path: root/third_party/nix/src/libutil/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/src/libutil/CMakeLists.txt
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/src/libutil/CMakeLists.txt')
-rw-r--r--third_party/nix/src/libutil/CMakeLists.txt68
1 files changed, 0 insertions, 68 deletions
diff --git a/third_party/nix/src/libutil/CMakeLists.txt b/third_party/nix/src/libutil/CMakeLists.txt
deleted file mode 100644
index 0b36929218..0000000000
--- a/third_party/nix/src/libutil/CMakeLists.txt
+++ /dev/null
@@ -1,68 +0,0 @@
-# -*- mode: cmake; -*-
-add_library(nixutil SHARED)
-set_property(TARGET nixutil PROPERTY CXX_STANDARD 17)
-include_directories(${PROJECT_BINARY_DIR}) # for config.h
-target_compile_features(nixutil PUBLIC cxx_std_17)
-
-set(HEADER_FILES
-    affinity.hh
-    archive.hh
-    args.hh
-    compression.hh
-    config.hh
-    finally.hh
-    hash.hh
-    istringstream_nocopy.hh
-    json.hh
-    lazy.hh
-    lru-cache.hh
-    monitor-fd.hh
-    pool.hh
-    proto.hh
-    ref.hh
-    serialise.hh
-    status.hh
-    sync.hh
-    thread-pool.hh
-    types.hh
-    util.hh
-    visitor.hh
-    xml-writer.hh
-)
-
-target_sources(nixutil
-  PUBLIC
-    ${HEADER_FILES}
-
-  PRIVATE
-    affinity.cc
-    archive.cc
-    args.cc
-    compression.cc
-    config.cc
-    hash.cc
-    json.cc
-    serialise.cc
-    thread-pool.cc
-    util.cc
-    xml-writer.cc
-)
-
-target_link_libraries(nixutil
-  nixproto
-  absl::strings
-  absl::statusor
-  glog
-  BZip2::BZip2
-  LibLZMA::LibLZMA
-  Boost::context
-  brotlienc
-  brotlidec
-  ssl
-)
-
-# Install header files to include/libutil and mark them for automatic
-# inclusion in targets that link to this one.
-target_include_directories(nixutil PUBLIC "${nix_SOURCE_DIR}/src")
-INSTALL(FILES ${HEADER_FILES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/nix/libutil)
-INSTALL(TARGETS nixutil DESTINATION ${CMAKE_INSTALL_LIBDIR})