about summary refs log tree commit diff
path: root/third_party/nix/src/libutil/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke Granger-Brown <hg@lukegb.com>2020-06-21T16·20+0100
committerlukegb <lukegb@tvl.fyi>2020-06-21T20·42+0000
commit739a45f9e47f35680117af61dc1a3aa2f5615636 (patch)
treeb5c9f1884bfbe033e5648f5557e06db6e26a472c /third_party/nix/src/libutil/CMakeLists.txt
parenta54f155c0715b42cdee0485200658075fb6cf173 (diff)
chore(3p/nix): use GNUInstallDirs to determine output directory names r/1051
This ensures that we install both glog's .a and all the .so files we
generate into a single consistent output lib path (which is, err,
lib64, but whatever).

Change-Id: Ib6ac6eacf5f56e4b719cfb586db731efc122c31b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/544
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--third_party/nix/src/libutil/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/third_party/nix/src/libutil/CMakeLists.txt b/third_party/nix/src/libutil/CMakeLists.txt
index 395671e07c..43b9e8525f 100644
--- a/third_party/nix/src/libutil/CMakeLists.txt
+++ b/third_party/nix/src/libutil/CMakeLists.txt
@@ -55,4 +55,4 @@ target_link_libraries(nixutil
 # inclusion in targets that link to this one.
 target_include_directories(nixutil PUBLIC "${nix_SOURCE_DIR}/src")
 INSTALL(FILES ${HEADER_FILES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/nix/libutil)
-INSTALL(TARGETS nixutil DESTINATION lib)
+INSTALL(TARGETS nixutil DESTINATION ${CMAKE_INSTALL_LIBDIR})