about summary refs log tree commit diff
path: root/third_party/nix/src/libexpr/meson.build
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-21T03·56+0100
committerVincent Ambo <tazjin@google.com>2020-05-21T04·09+0100
commitc395a48be2ad58560590897e11793db032873ed6 (patch)
tree11cc692b442c10db9f1a6055cfe68bc534e6f494 /third_party/nix/src/libexpr/meson.build
parent97e85f94e5ee7e6c8340011757a71222b8091cda (diff)
fix(3p/nix): Compatibility with updated SymbolTable r/795
The functions in SymbolTable have been renamed to match the Google
Style guide, and some debug-only functions have been removed.
Diffstat (limited to 'third_party/nix/src/libexpr/meson.build')
-rw-r--r--third_party/nix/src/libexpr/meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/third_party/nix/src/libexpr/meson.build b/third_party/nix/src/libexpr/meson.build
index 7ddd4cff4ecb..1bb311e999d1 100644
--- a/third_party/nix/src/libexpr/meson.build
+++ b/third_party/nix/src/libexpr/meson.build
@@ -16,6 +16,7 @@ libexpr_src = files(
     join_paths(meson.source_root(), 'src/libexpr/names.cc'),
     join_paths(meson.source_root(), 'src/libexpr/nixexpr.cc'),
     join_paths(meson.source_root(), 'src/libexpr/primops.cc'),
+    join_paths(meson.source_root(), 'src/libexpr/symbol-table.cc'),
     join_paths(meson.source_root(), 'src/libexpr/value-to-json.cc'),
     join_paths(meson.source_root(), 'src/libexpr/value-to-xml.cc'),
 )
@@ -42,18 +43,17 @@ libexpr_dep_list = [
     glog_dep,
     libdl_dep,
     libsodium_dep,
-]
-
-if sys_name == 'freebsd'
-    libexpr_dep_list += libdl_dep
-endif
+] + absl_deps
 
 libexpr_link_list = [
     libutil_lib,
     libstore_lib,
-    libmain_lib]
+    libmain_lib,
+]
 
-libexpr_link_args = []
+libexpr_link_args = [
+  '-lpthread',
+]
 
 libexpr_cxx_args = []