about summary refs log tree commit diff
path: root/third_party/nix/src/libexpr/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-16T19·28+0100
committertazjin <mail@tazj.in>2020-07-16T19·53+0000
commit5ae2a2b847f94e39932c7abd06662d990773649a (patch)
tree0d2b45c6fb629d81a6e3fdd20f1796f3669d3335 /third_party/nix/src/libexpr/CMakeLists.txt
parentd579ceb7830406ae743aa3da274017d5e8a7bfa7 (diff)
refactor(3p/nix/libexpr): Extract static helpers out of parser.y r/1322
Moves several of the static helper functions into a new parser.cc
file.

Once the rest of the code is usefully extracted, these will be moved
to a private namespace.

Change-Id: I0d7b53dcefe31bb5c6bad3ad7f5fcb48276bf799
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1218
Tested-by: BuildkiteCI
Reviewed-by: isomer <isomer@tvl.fyi>
Diffstat (limited to 'third_party/nix/src/libexpr/CMakeLists.txt')
-rw-r--r--third_party/nix/src/libexpr/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/third_party/nix/src/libexpr/CMakeLists.txt b/third_party/nix/src/libexpr/CMakeLists.txt
index d2e991657b..693b618c66 100644
--- a/third_party/nix/src/libexpr/CMakeLists.txt
+++ b/third_party/nix/src/libexpr/CMakeLists.txt
@@ -59,6 +59,7 @@ target_sources(nixexpr
     json-to-value.cc
     names.cc
     nixexpr.cc
+    parser.cc
     primops.cc
     symbol-table.cc
     value-to-json.cc