about summary refs log tree commit diff
path: root/third_party/nix/src/libexpr/CMakeLists.txt
diff options
context:
space:
mode:
authorKane York <kanepyork@gmail.com>2020-08-13T23·51-0700
committerkanepyork <rikingcoding@gmail.com>2020-08-17T02·23+0000
commit38f2ea34f466d8264f7a060627eece5b3cbc40ba (patch)
treeb7acbd7e206643719990e5f0b9a78294ed268696 /third_party/nix/src/libexpr/CMakeLists.txt
parentcbebc75d94f02659c8d90211fa6acd16c606e6a4 (diff)
refactor(tvix): add explicit copy/move constructors for Value r/1657
This is in preparation for making some of Value's members into refcounted ('smart') pointers.

Change-Id: Ibc54e23ac35766a2fd4e14871c9a7c936a603778
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1743
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/nix/src/libexpr/CMakeLists.txt')
-rw-r--r--third_party/nix/src/libexpr/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/third_party/nix/src/libexpr/CMakeLists.txt b/third_party/nix/src/libexpr/CMakeLists.txt
index 7a6b01a9d4..8cb7143d2c 100644
--- a/third_party/nix/src/libexpr/CMakeLists.txt
+++ b/third_party/nix/src/libexpr/CMakeLists.txt
@@ -62,6 +62,7 @@ target_sources(nixexpr
     parser.cc
     primops.cc
     symbol-table.cc
+    value.cc
     value-to-json.cc
     value-to-xml.cc
 )