about summary refs log tree commit diff
path: root/third_party/nix/src/libexpr/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke Granger-Brown <hg@lukegb.com>2020-06-21T15·58+0100
committerlukegb <lukegb@tvl.fyi>2020-06-21T20·42+0000
commita54f155c0715b42cdee0485200658075fb6cf173 (patch)
tree46870e99d7cb8c11f5a1e8e4f34c3211e6c0a7d4 /third_party/nix/src/libexpr/CMakeLists.txt
parent1ff26fb8c5de927467bc58d01dcb233f9b335771 (diff)
chore(3p/nix): export library headers to include/ in output. r/1050
Change-Id: I87eb6e59782d720015d351d8829dc7b8688e01f2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/543
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/nix/src/libexpr/CMakeLists.txt')
-rw-r--r--third_party/nix/src/libexpr/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/third_party/nix/src/libexpr/CMakeLists.txt b/third_party/nix/src/libexpr/CMakeLists.txt
index 3456052ea9..d85cb24c81 100644
--- a/third_party/nix/src/libexpr/CMakeLists.txt
+++ b/third_party/nix/src/libexpr/CMakeLists.txt
@@ -18,8 +18,7 @@ FLEX_TARGET(NixLexer lexer.l
 
 ADD_FLEX_BISON_DEPENDENCY(NixLexer NixParser)
 
-target_sources(nixexpr
-  PUBLIC
+set(HEADER_FILES
     attr-path.hh
     attr-set.hh
     common-eval-args.hh
@@ -35,6 +34,11 @@ target_sources(nixexpr
     value.hh
     value-to-json.hh
     value-to-xml.hh
+)
+
+target_sources(nixexpr
+  PUBLIC
+    ${HEADER_FILES}
 
   PRIVATE
     ${PROJECT_BINARY_DIR}/generated/parser-tab.hh
@@ -72,4 +76,5 @@ target_link_libraries(nixexpr
   gccpp
 )
 
+INSTALL(FILES ${HEADER_FILES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/nix/libexpr)
 INSTALL(TARGETS nixexpr DESTINATION lib)