about summary refs log tree commit diff
path: root/third_party/nix/src/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-08-03T18·05+0100
committertazjin <mail@tazj.in>2020-08-03T18·26+0000
commit1f12544179041b151f146fbb604e9af165ffe379 (patch)
treef1cba1958e25749cd9a85192c672d1ffb9aca82b /third_party/nix/src/CMakeLists.txt
parent229c1ed820fe20515a69f749c38d5f9f89d20c8d (diff)
refactor(3p/nix): Build nix-daemon as a separate binary r/1569
Skips over all the monobinary stuff and moves to a separate binary for
nix-daemon.

This also replaces the flag parsing logic with absl::flags. This
causes a behaviour change for --help, which no longer tries to display
a man page but instead shows the actual command-line help.

Note: This binary no longer links to the Boehm GC.

Change-Id: Ib852e994b82f2d56e91262878c10650e656427a9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1622
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/nix/src/CMakeLists.txt')
-rw-r--r--third_party/nix/src/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/third_party/nix/src/CMakeLists.txt b/third_party/nix/src/CMakeLists.txt
index a142bfafb4..486c69fa2a 100644
--- a/third_party/nix/src/CMakeLists.txt
+++ b/third_party/nix/src/CMakeLists.txt
@@ -10,6 +10,7 @@ add_subdirectory(libutil)
 add_subdirectory(libstore)
 add_subdirectory(libmain)
 add_subdirectory(libexpr)
+add_subdirectory(nix-daemon)
 
 if (PACKAGE_TESTS)
   add_subdirectory(tests)
@@ -61,8 +62,6 @@ target_sources(nix
     nix-channel/nix-channel.cc
     nix-collect-garbage/nix-collect-garbage.cc
     nix-copy-closure/nix-copy-closure.cc
-    nix-daemon/nix-daemon-proto.cc
-    nix-daemon/nix-daemon-main.cc
     nix-env/nix-env.cc
     nix-env/user-env.cc
     nix-instantiate/nix-instantiate.cc