about summary refs log tree commit diff
path: root/third_party/nix/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-23T16·35-0400
committerglittershark <grfn@gws.fyi>2020-07-25T20·11+0000
commitdcaba9de64354fa699ee6b292efbedfb984582db (patch)
tree00d82d265d06eec49d6b729941d803801f34707b /third_party/nix/src/CMakeLists.txt
parent7c56fccdad85c5d99c1a79e0768ce3d20aac82e9 (diff)
feat(3p/nix): Add main function for grpc daemon r/1472
Implement the main function for the new, proto-based nix daemon. This
mostly replicates the behavior of the previous nix daemon - it starts a
grpc server listening on the same nix socket path and supports the same
set of options - with the exception of --stdio, which has been renamed
to --pipe and documented in the man page.

Change-Id: Ib729283c1d5d35c0e1b0a968bc1f052f5527f2d7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1356
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Diffstat (limited to 'third_party/nix/src/CMakeLists.txt')
-rw-r--r--third_party/nix/src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/third_party/nix/src/CMakeLists.txt b/third_party/nix/src/CMakeLists.txt
index 3775333ee3..a142bfafb4 100644
--- a/third_party/nix/src/CMakeLists.txt
+++ b/third_party/nix/src/CMakeLists.txt
@@ -61,8 +61,8 @@ target_sources(nix
     nix-channel/nix-channel.cc
     nix-collect-garbage/nix-collect-garbage.cc
     nix-copy-closure/nix-copy-closure.cc
-    nix-daemon/nix-daemon.cc
     nix-daemon/nix-daemon-proto.cc
+    nix-daemon/nix-daemon-main.cc
     nix-env/nix-env.cc
     nix-env/user-env.cc
     nix-instantiate/nix-instantiate.cc