about summary refs log tree commit diff
path: root/third_party/nix/shell.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-17T15·27+0100
committerVincent Ambo <tazjin@google.com>2020-05-17T15·28+0100
commitc94ef8d00b248339f5dfcdda7b9d102a56f06bc7 (patch)
tree34ed8ce8ce5c230b9095fe91163166de43d9000e /third_party/nix/shell.nix
parent939cec746edca8c00893cd72e5d8556eecdb367f (diff)
chore(3p/nix): Use packages from depot tree r/738
Diffstat (limited to '')
-rw-r--r--third_party/nix/shell.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/third_party/nix/shell.nix b/third_party/nix/shell.nix
index e8026f8e40..e163fccf9c 100644
--- a/third_party/nix/shell.nix
+++ b/third_party/nix/shell.nix
@@ -1,10 +1,9 @@
-{ useClang ? false }:
-
-with import (builtins.fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz) {};
+let pkgs = (import <nixpkgs> {}).third_party;
+in with pkgs;
 
 with import ./release-common.nix { inherit pkgs; };
 
-(if useClang then clangStdenv else stdenv).mkDerivation {
+clangStdenv.mkDerivation {
   name = "nix";
 
   buildInputs = buildDeps ++ propagatedDeps ++ tarballDeps ++ perlDeps;