about summary refs log tree commit diff
path: root/third_party/nix/meson.build
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-17T22·58+0100
committerVincent Ambo <tazjin@google.com>2020-05-17T22·58+0100
commit0335b91b9357f517dfcecb1a4681f337634fed31 (patch)
treef743a9ec87473514888ba30fb15459868be34f4d /third_party/nix/meson.build
parentffdeb3bbf136120a25140077d0295b3ff9d326d6 (diff)
feat(3p/nix): Add glog dependency r/750
Diffstat (limited to 'third_party/nix/meson.build')
-rw-r--r--third_party/nix/meson.build13
1 files changed, 6 insertions, 7 deletions
diff --git a/third_party/nix/meson.build b/third_party/nix/meson.build
index bd5cd8ce7e..78b84617a5 100644
--- a/third_party/nix/meson.build
+++ b/third_party/nix/meson.build
@@ -417,8 +417,13 @@ libdl_dep = declare_dependency(
 #--------------------------------------------------
 libbz2_dep = declare_dependency(
     dependencies : cpp.find_library('bz2'),
-    link_args :  get_option('bz2_link_args'))
+    link_args : get_option('bz2_link_args'))
 
+# Look for glog, a required dependency.
+#--------------------------------------
+glog_dep = declare_dependency(
+  dependencies : cpp.find_library('glog'),
+  link_args : get_option('glog_link_args'))
 
 # Look for editline, a required dependency.
 #--------------------------------------------------
@@ -441,8 +446,6 @@ if not (
 endif
 
 
-
-
 # Optional dependancies
 #============================================================================
 
@@ -485,8 +488,6 @@ if (get_option('with_s3'))
 endif
 
 
-
-
 # OS Specific checks
 #============================================================================
 # Look for libsecppomp, required for Linux sandboxing.
@@ -512,8 +513,6 @@ if (sys_name.contains('sunos'))
 endif
 
 
-
-
 # build
 #============================================================================