about summary refs log tree commit diff
path: root/third_party/nix/meson.build
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-21T18·20+0100
committerVincent Ambo <tazjin@google.com>2020-05-21T18·21+0100
commit28e347effe1ba4325fc485e920bda45c838e0450 (patch)
treede476a8bd0138bce979c14bab45c6f22714585a1 /third_party/nix/meson.build
parent1bb9cd7749748ee7019efcde834bbdb2b56e68e1 (diff)
refactor(3p/nix/libexpr): Use absl::btree_map for AttrSets r/799
This is the first step towards replacing the implementation of
attribute sets with an absl::btree_map.

Currently many access are done using array offsets and pointer
arithmetic, so this change is currently causing Nix to fail in various
ways.
Diffstat (limited to 'third_party/nix/meson.build')
-rw-r--r--third_party/nix/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/third_party/nix/meson.build b/third_party/nix/meson.build
index 1b5e030bde..8e845c20e2 100644
--- a/third_party/nix/meson.build
+++ b/third_party/nix/meson.build
@@ -354,6 +354,7 @@ absl_deps = [
   absl.dependency('algorithm_container'),
   absl.dependency('base'),
   absl.dependency('bits'),
+  absl.dependency('btree'),
   absl.dependency('city'),
   absl.dependency('config'),
   absl.dependency('container_common'),