about summary refs log tree commit diff
path: root/third_party/nix/default.nix
diff options
context:
space:
mode:
authorLuke Granger-Brown <hg@lukegb.com>2020-06-21T20·41+0100
committerlukegb <lukegb@tvl.fyi>2020-06-21T23·49+0000
commit4de63f784c53f5400cc454f6faadc907b34f4ac2 (patch)
tree086a57f03f5a2b94dcc7c67ff67bad883a3125c0 /third_party/nix/default.nix
parentb99829f142a6de8360e282348b60b4c3c0f210b5 (diff)
fix(3p/nix): propagate dependencies which are needed by people linking in nix r/1055
This includes absl, which we install into the output, and boost and the boehm GC,
which are moved to propagated deps.

Change-Id: I8f9f9795ff92e26b2320359064241d7fd59c2d33
Reviewed-on: https://cl.tvl.fyi/c/depot/+/549
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--third_party/nix/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/third_party/nix/default.nix b/third_party/nix/default.nix
index c31de41edd..e6fa3f1f7d 100644
--- a/third_party/nix/default.nix
+++ b/third_party/nix/default.nix
@@ -36,13 +36,11 @@ in pkgs.llvmPackages.libcxxStdenv.mkDerivation {
  # TODO(tazjin): Some of these might only be required for native inputs
   buildInputs = with pkgs; [
     aws-s3-cpp
-    boost
     brotli
     bzip2
     curl
     editline
     flex
-    largeBoehm
     libseccomp
     libsodium
     openssl
@@ -50,6 +48,11 @@ in pkgs.llvmPackages.libcxxStdenv.mkDerivation {
     xz
   ];
 
+  propagatedBuildInputs = with pkgs; [
+    boost
+    largeBoehm
+  ];
+
   # Install the various symlinks to the Nix binary which users expect
   # to exist.
   postInstall = ''