about summary refs log tree commit diff
path: root/third_party/nix/default.nix
diff options
context:
space:
mode:
authorKane York <kanepyork@gmail.com>2020-07-23T18·55-0700
committerkanepyork <rikingcoding@gmail.com>2020-07-23T21·46+0000
commitb8e94002d6a0a416a3128e1bc275d73f59700321 (patch)
tree1a08833539e179abedde4590e37041c6aaeab2ee /third_party/nix/default.nix
parentbe98295dc24492f6607cce04ba586e3897a83543 (diff)
feat(3p/nix): run clang-tidy during builds r/1435
We need to -isystem the libcxx header files in order for clang-tidy to ignore them, as the Nix clang toolchain isn't doing that automatically.

Change-Id: I05b9e9bd522de4c0e2ad543214f6bf6ab66a306b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1359
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--third_party/nix/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/third_party/nix/default.nix b/third_party/nix/default.nix
index bbd0e0120a..bc25689461 100644
--- a/third_party/nix/default.nix
+++ b/third_party/nix/default.nix
@@ -81,7 +81,6 @@ in pkgs.llvmPackages.libcxxStdenv.mkDerivation {
     mkdir build
     cd build
     cmake .. \
-      -DCMAKE_CXX_FLAGS='-Wall -Werror' \
       -DCMAKE_INSTALL_PREFIX=$out \
       -DCMAKE_BUILD_TYPE=Release \
       -DCMAKE_FIND_USE_SYSTEM_PACKAGE_REGISTRY=OFF \
@@ -110,6 +109,9 @@ in pkgs.llvmPackages.libcxxStdenv.mkDerivation {
   # that they can be included by CMake.
   NIX_PROTO_SRCS = protoSrcs;
 
+  # Work around broken system header include flags in the cxx toolchain.
+  LIBCXX_INCLUDE = "${pkgs.llvmPackages.libcxx}/include/c++/v1";
+
   # Install the various symlinks to the Nix binary which users expect
   # to exist.
   postInstall = ''