about summary refs log tree commit diff
path: root/third_party/nix/corepkgs/buildenv.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-30T16·06+0300
committertazjin <tazjin@tvl.su>2022-01-31T16·11+0000
commitaa122cbae78ce97d60c0c98ba14df753d97e40b1 (patch)
tree12b98d85c4b18fe870feb26de70db9ba61837bd7 /third_party/nix/corepkgs/buildenv.nix
parent2d10d60fac0fd00a71b65cfdcb9fba0477b2086c (diff)
style: format entire depot with nixpkgs-fmt r/3723
This CL can be used to compare the style of nixpkgs-fmt against other
formatters (nixpkgs, alejandra).

Change-Id: I87c6abff6bcb546b02ead15ad0405f81e01b6d9e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4397
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: cynthia <cynthia@tvl.fyi>
Reviewed-by: edef <edef@edef.eu>
Reviewed-by: eta <tvl@eta.st>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'third_party/nix/corepkgs/buildenv.nix')
-rw-r--r--third_party/nix/corepkgs/buildenv.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/third_party/nix/corepkgs/buildenv.nix b/third_party/nix/corepkgs/buildenv.nix
index 0bac4c44b4..4da0db2ae2 100644
--- a/third_party/nix/corepkgs/buildenv.nix
+++ b/third_party/nix/corepkgs/buildenv.nix
@@ -9,11 +9,13 @@ derivation {
 
   # !!! grmbl, need structured data for passing this in a clean way.
   derivations =
-    map (d:
-      [ (d.meta.active or "true")
-        (d.meta.priority or 5)
-        (builtins.length d.outputs)
-      ] ++ map (output: builtins.getAttr output d) d.outputs)
+    map
+      (d:
+        [
+          (d.meta.active or "true")
+          (d.meta.priority or 5)
+          (builtins.length d.outputs)
+        ] ++ map (output: builtins.getAttr output d) d.outputs)
       derivations;
 
   # Building user environments remotely just causes huge amounts of