about summary refs log tree commit diff
path: root/third_party/nix/clangd.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/clangd.nix
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/clangd.nix')
-rw-r--r--third_party/nix/clangd.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/third_party/nix/clangd.nix b/third_party/nix/clangd.nix
deleted file mode 100644
index 7a29819b10..0000000000
--- a/third_party/nix/clangd.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-# Create a clangd wrapper script that can be used with this project.
-# The default Nix wrapper only works with C projects, not C++
-# projects.
-#
-# The CPATH construction logic is lifted from the original wrapper
-# script.
-
-pkgs:
-
-pkgs.writeShellScriptBin "nix-clangd" ''
-  buildcpath() {
-    local path
-    while (( $# )); do
-      case $1 in
-          -isystem)
-              shift
-              path=$path''${path:+':'}$1
-      esac
-      shift
-    done
-    echo $path
-  }
-
-  export CPATH=''${CPATH}''${CPATH:+':'}:$(buildcpath ''${NIX_CFLAGS_COMPILE})
-  export CPATH=${pkgs.glibc.dev}/include''${CPATH:+':'}''${CPATH}
-  export CPLUS_INCLUDE_PATH=${pkgs.llvmPackages_11.libcxx}/include/c++/v1:''${CPATH}
-
-  # TODO(tazjin): Configurable commands directory?
-  exec -a clangd ${pkgs.llvmPackages_11.clang-unwrapped}/bin/clangd -cross-file-rename $@
-''